Electronic mail, Computer Network Security

Assignment Help:

Electronic Mail:

Electronic mail which is famous as e-mail, as it is known to its number of users, has been around for more than two decades. Before 1990, it was mainly used in academia. During the 1990s, it became popular to the public at large and grew exponentially to the point where the number of e-mails sent per day now is immensely more than the number of snail mail (that is paper) letters.

E-mail, similar to most other forms of the communication, has conventions and styles its own. In particular, it is quite informal and has the low threshold of use. People who could never dream of calling up or even writing a letter to a especially Important Person do not hesitate for a second to send a sloppily-written e-mail.

E-mail is full with the jargon such as ROTFL (Rolling On The Floor Laughing), an IMHO (In My Humble Opinion) BTW (By The Way).  Number of people also uses little ASCII symbols which are commonly known as smiley's or emoticons in their e-mail.

The first e-mail systems simply comprised of the file transfer protocols, with the convention with the first line of each message (which is file) contained the recipient's address. As time passed, the limitations of this approach became much more obvious.

Some of the complaints were as written below:

1. Sending a message to the group of people was very much inconvenient. Managers often required this facility to send memos to all of the subordinates.

2. Messages did not have internal structure, making computer processing complicated. For instance, if a forwarded message was included in the body of any other message, extracting the forwarded part from received message was complex.

3. The originator (sender) never knew if a message had come or not.

4. If someone was scheduling to be away on business for several weeks and wanted all the incoming e-mail to be handled by his secretary, this was not at all easy to arrange.

5. The user interface was very poorly integrated with the transmission system desiring users first to edit the file, then leave the editor and appeal to the file transfer program.

6. It was not achievable to create and send messages the containing a mixture of the text, drawings, facsimile, and voice.

As experience and was gained, more elaborate e-mail systems were introduced. In 1982, the ARPANET e-mail ideas were published as the RFC 821 (which is transmission protocol) and RFC 822 (which is message format). Minor revisions in the, RFC 2821 and RFC 2822, have become the Internet standards, but everyone still refers to Internet e-mail as RFC 822.

In 1984, the CCITT drafted its  own X.400 proposal. After the two decades of the competition, e- mail  systems  based  on the RFC  822  are  commonly  used,  whereas  those  based  on the  X.400  have vanished. How a system hacked together by the handful of computer science graduate students beat  the official  international  standard  powerfully  backed  by all  the  PTTs  in  the  world,  a lot of governments, and a considerable part of the computer industry brings to mind the Biblical story of the David and Goliath.

The reason for the RFC 822's success is not that it is very good, but that X.400 was so weakly designed and so complex that nobody could execute it well. Given the choice between a simple- minded,  but working,  RFC 822-based  e-mail system and a allegedly  truly  wonderful,  but nonworking, X.400 e-mail system, most of the organizations chose the previous.


Related Discussions:- Electronic mail

What are the ethical issues and implications, An injunction to 'think ethic...

An injunction to 'think ethically' about a situation is not helpful. Perhaps if one has a background in moral philosophy this would work, but usually both students and IT professio

Risk control strategies-, Risk Control Strategies Once the ranked vulner...

Risk Control Strategies Once the ranked vulnerability risk worksheet has created, they should choose one of following 4 strategies to control each risk: •Apply safeguards which

How to create a security policy, Five years ago, Calgary Kids' Cloth Ltd wa...

Five years ago, Calgary Kids' Cloth Ltd was just a small retail store in downtown Calgary. The company started their own factory in SE Calgary to produce outdoor clothes for kids.

What is data spoliation, QUESTION (a) What do you meant by data spoli...

QUESTION (a) What do you meant by data spoliation? (b) Justify the following statement: "Disk imaging differs from creating a standard backup of disk." (c) Why do yo

Describe phishing attacks, QUESTION (a) (i) Describe Phishing attacks. ...

QUESTION (a) (i) Describe Phishing attacks. (ii) Distinguish between Phishing and Spear Phishing attacks. (b) Describe two instances where an attacker sniffing on a netwo

Factors of informtion security, Confidentiality Confidentiality of inform...

Confidentiality Confidentiality of information ensures that only those with sufficient privileges may access specific information. When unauthorized individuals can access inform

Syntax conversion, Write down the significance of the syntax conversion . S...

Write down the significance of the syntax conversion . Syntax Conversion is described below: Syntax conversion is a significant function carried out in the presentation layer. I

Sending an arp message, Normal 0 false false false EN-U...

Normal 0 false false false EN-US X-NONE X-NONE

How an attacker can effectively de-layer and analyse data, Around the globe...

Around the globe the bank controlled Co-ops (Visa, MasterCard, Discover, and American Express) have rolled out millions of smart cards under the EMV (Europay, MasterCard, VISA) sta

Plain-text using play-fair encryption, What is one-time pad for encryp...

What is one-time pad for encryption?  Describe how it offers both Confusion and Diffusion. Using the letter encoding discussed in class (along with one-time

Write Your Message!

Captcha
Free Assignment Quote

Assured A++ Grade

Get guaranteed satisfaction & time on delivery in every assignment order you paid with us! We ensure premium quality solution document along with free turntin report!

All rights reserved! Copyrights ©2019-2020 ExpertsMind IT Educational Pvt Ltd